Custom Widgetset for Mgnl 5.5
#1 by chrspr on Dec 5, 2017 10:11:17 AM

AFAIK Magnolia 5.5 still relies on Vaadin 7.7, which again depends on a GWT version that doesn't support Java 8 language level.

On the other hand it looks like even the widgetsets of Magnolia 5.5.x habe lambda expressions, e.g.


addStateChangeHandler("hasCloseButton", stateChangeEvent -> {
if (getState().hasCloseButton) {
view.showCloseButton();
}
});


This is out from magnolia-ui-vaadin-common-widgets-5.5.6.

This gives me errors like


Tracing compile failure path for type 'info.magnolia.ui.vaadin.gwt.client.dialog.connector.BaseDialogConnector'
[INFO] [ERROR] Errors in 'jar:file:/C:/Users/Christian/.m2/repository/info/magnolia/ui/magnolia-ui-vaadin-common-widgets/5.5.6/magnolia-ui-vaadin-common-widgets-5.5.6.jar!/info/magnolia/ui/vaadin/gwt/client/dialog/connector/BaseDialogConnector.java'
[INFO] [ERROR] Line 67: Lambda expressions are allowed only at source level 1.8 or above



when using <sourceLevel>1.7</sourceLevel> for the vaadin-maven-plugin

When setting <sourceLevel>1.8</sourceLevel> there are exceptions like this:


[ERROR] Source level must be one of [auto, 1.6, 1.7].
[ERROR] Google Web Toolkit 7.7.0
[ERROR] Compiler [-logLevel level] [-workDir dir] [-[no]compileReport] [-X[no]checkCasts] [-X[no]classMetadata] [-[no]draftCompile] [-[no]checkAssertions] [-X[no]closureCompiler] [-XfragmentCount numFragments] [-XfragmentMerge numFragments] [-gen dir] [-[no]incr
ementalCompileWarnings] [-XjsInteropMode [NONE, JS, CLOSURE]] [-missingDepsFile file] [-Xnamespace PACKAGE, NONE] [-optimize level] [-[no]overlappingSourceWarnings] [-[no]saveSource] [-style style] [-[no]failOnError] [-X[no]enforceStrictResources] [-[no]validate
Only] [-sourceLevel [auto, 1.6, 1.7]] [-localWorkers count] [-[no]incremental] [-war dir] [-deploy dir] [-extra dir] [-saveSourceOutput dir] [-XmethodNameDisplayMode NONE | ONLY_METHOD_NAME | ABBREVIATED | FULL] module[s]


sourceLevel=auto doesn't do the trick either

How can I create custom widgetsets for Mgnl 5.5.x?

Thx